BMW: help e39 2001 525d , will not rev and dde light : BMW 5 series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2014                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

help e39 2001 525d , will not rev and dde light

BMW forum 5 series car: E12, E28, E34, E39, E60, E61, F07, F10, F11

Moderator: Moderators

help e39 2001 525d , will not rev and dde light

Postby nokianeeds2 » Tue, 23 Jun 2009 14:17:19 UTC

Hi guys

my cars accelarator stopped responding the other day and up came the dde light, i assumed it was the accelarator pedal unit, so replaced. car still same,

had an eleccy out to it today and read the following fault codes

p0190 fuel pressure sensor

1255 fuel low

1e60 sensor voltage supply

any ideas as to what it may be causing it and any furthyer ideas as where the fuel pressure sensor is located?
nokianeeds2
User

Posts: 17
Joined: Thu, 10 Jul 2008 18:13:30 UTC

Postby nokianeeds2 » Tue, 23 Jun 2009 15:20:59 UTC

it idles as normal but when the accelarator is pressed it will only go up to 1200rpm and stay there even when the I lift off the acc pedal
nokianeeds2
User

Posts: 17
Joined: Thu, 10 Jul 2008 18:13:30 UTC

Postby E39mad » Tue, 23 Jun 2009 15:22:40 UTC

Could be the fuel pumps - there are two one under the passenger seat - common fault on these cars.

Could also be the MAF - this can be unplugged to check.
F11 520d SE Sport Auto Comfort Seats Deep Sea Blue

E36 328i Mtec vert man Avus Blue

Gone: E39s 530i Individual, 525d Sport touring man, E46 330d touring, E36 318is, E21 316
E39mad
BMW Warlord

Posts: 3808
Images: 0
Joined: Mon, 02 Oct 2006 15:01:09 UTC
BMW Members Cars: F11 520d SE
2000 328i Mtec convertible
Location: Cheshire
England (EN)

Postby terminator » Tue, 23 Jun 2009 15:25:58 UTC

The problem could be a faulty in line fuel pump, which is situated underneath the car (under the passenger seat behind a plastic cover. These are prone to failing prematurely on the E39 diesels and will likely give rise to the fault codes you are experiencing. (E39Mad and I must have posted at approx the same time but both agree)!
Hasta La Vista, baby!
terminator
BMW Warlord
Site Supporter

User avatar

Posts: 1151
Joined: Sat, 14 Oct 2006 21:08:32 UTC
Location: The Future and West Sussex

Postby Clavurion » Tue, 23 Jun 2009 21:01:31 UTC

I guess those codes are not checked by BMW software. It could be:
*1190 Rail pressure control (will also light up DDE warning)
*1255 Presupply pressure sensor
*1260 Presupply pressure monitoring

Those codes simultaneously usually points to faulty inline fuel pump. The car doesn't rev above ~3000 RPM while driving?
E39 530dA
Clavurion
BMW Warlord

Posts: 1871
Joined: Fri, 23 Feb 2007 01:42:46 UTC
Location: Finland

Postby nokianeeds2 » Sat, 27 Jun 2009 20:26:43 UTC

cheers guys, gona attempt the pump this week, hope it cures . . .
nokianeeds2
User

Posts: 17
Joined: Thu, 10 Jul 2008 18:13:30 UTC

Postby nokianeeds2 » Mon, 29 Jun 2009 11:48:18 UTC

Clavurion wrote:I guess those codes are not checked by BMW software. It could be:
*1190 Rail pressure control (will also light up DDE warning)
*1255 Presupply pressure sensor
*1260 Presupply pressure monitoring

Those codes simultaneously usually points to faulty inline fuel pump. The car doesn't rev above ~3000 RPM while driving?


the car doesnt rev at all, its just sits at idle . . .no response from the accelarator
nokianeeds2
User

Posts: 17
Joined: Thu, 10 Jul 2008 18:13:30 UTC

Postby nokianeeds2 » Sat, 04 Jul 2009 14:18:27 UTC

inline fuel pump placed, under passenger seat. still no go.

anymore suggestions before it goes to the stealers for me to get raped lol
nokianeeds2
User

Posts: 17
Joined: Thu, 10 Jul 2008 18:13:30 UTC

Postby mick-da-yid » Mon, 06 Jul 2009 13:11:05 UTC

You could try changing the diesel filter, easy and cheap to do. Mine got clogged up, I changed it and made a huge difference.
To dare is to do. C.O.Y.S.
Everyone is entitled to my opinion
mick-da-yid
Overdrive

Posts: 442
Joined: Tue, 12 Jun 2007 21:25:15 UTC
BMW Members Cars: F30 320ED Touring Auto
E39 530d Sport Touring Auto.
Location: Essex
England (EN)

Postby nokianeeds2 » Wed, 22 Jul 2009 15:40:28 UTC

just to update you guys incase someone else develops this fault, it was a faulty sensor on the high pressure fuel rail. , bummer as i replaced every part imaginable and ended up being a £65 part that needed replacing
nokianeeds2
User

Posts: 17
Joined: Thu, 10 Jul 2008 18:13:30 UTC


  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW 5 series Forum

BMWLand: Who is online

Users browsing this BMW forum: milnei, nvHerman, Yahoo [Bot] and 39 guests