BMW: the dreaded shimmer at 50 mph : BMW 5 series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2014                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

the dreaded shimmer at 50 mph

BMW forum 5 series car: E12, E28, E34, E39, E60, E61, F07, F10, F11

Moderator: Moderators

the dreaded shimmer at 50 mph

Postby philip bl » Fri, 12 Jan 2007 22:44:50 UTC

hi every body

not posted for a long time but i would just like to ask how many people who own a e39 have had the dreaded shimmer at 50- 60 mph
also when you press the brake pedal you get it
i have just started to get it on my car

also if you have had it what is the main part on the car that caused it

cheers

phil
e39 540i
philip bl
Intermediate

Posts: 146
Joined: Sat, 27 Aug 2005 12:01:02 UTC

Postby Golfather » Fri, 12 Jan 2007 23:52:48 UTC

A common problem judging by the number of posts on the topic.

Could be due to one of the following:

1. Sticking brake caliper
2. Wheel balancing
3. Tracking
4. Discs/Pads

Start with the wheels and then get the caliper checked if the problem persists.
"The Lord of the Rings"

2004 Ebony Black RS6 Avant | Milltek Non-res | Alpine 7" Multimedia/PC/DVD | MRC Stage 1+
2003 Avus Silver RS6 Saloon | Milltek Non-Res | RNS-E | MRC Stage 1+
XC90 D5 SE Geartronic
Golfather
BMW Warlord

User avatar

Posts: 1798
Joined: Sun, 29 May 2005 21:25:31 UTC
Location: UK

Postby kingjohn » Sat, 13 Jan 2007 00:17:12 UTC

Check your tyre pressures first.

John
kingjohn
User

Posts: 48
Joined: Tue, 29 Aug 2006 16:15:24 UTC

Postby philip bl » Sat, 13 Jan 2007 11:54:10 UTC

cheers guy

will check

phil
philip bl
Intermediate

Posts: 146
Joined: Sat, 27 Aug 2005 12:01:02 UTC

Postby FRAJ » Sat, 13 Jan 2007 11:54:16 UTC

A few people have mentioned this, but what exatly are the symptoms? On the straight? When braking etc? I'm just interested & expecting something on my car.
540i Touring, 2001
FRAJ
User

Posts: 31
Joined: Fri, 03 Nov 2006 20:47:41 UTC

Postby philip bl » Sat, 13 Jan 2007 17:23:40 UTC

hi guys

just to let you know
i have been to G F S AND EURO car parts and payed for all the front suspension parts this includes
both lower control arms L and R new
both anti roll bar tie rods L AND R new
Steering linkage ball joints new

i will be fitting them on sunday so will let you all know if it fixes the shimmer

phil
philip bl
Intermediate

Posts: 146
Joined: Sat, 27 Aug 2005 12:01:02 UTC

Postby madwak » Sat, 13 Jan 2007 21:08:18 UTC

I think the discs are the main culprit, I had it on mine very noticable when braking and barely noticeble while driving. Took the car to a fast fit centre for a free brake check and they checked the runout on the discs, found they were warped and they then pointed out that some of the rusty stuff on the outside edge of inside disc had broken off and took some of the good surface with it, this accounted for the problem getting worse when braking.
So off I went to the indy got the discs and pads changed and the shimmy is now gone.
I'm now watching with interest to see if phillip bl stil has to change the discs after replacing all those parts tomorrow.
madwak
Advanced

User avatar

Posts: 655
Joined: Sun, 11 Sep 2005 12:26:37 UTC
Location: YORKSHIRE

Postby philip bl » Sat, 13 Jan 2007 21:19:56 UTC

hi

just to let you know discs and pads are ok, i checked them before i went to get other parts
all so they are only 6 months old

regards

phil
philip bl
Intermediate

Posts: 146
Joined: Sat, 27 Aug 2005 12:01:02 UTC

Postby philip bl » Sun, 14 Jan 2007 13:37:09 UTC

hi guys

just finish

all fitted and been out in it all is now ok
job done
great my old car back again


cheers
phil
philip bl
Intermediate

Posts: 146
Joined: Sat, 27 Aug 2005 12:01:02 UTC


  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW 5 series Forum

BMWLand: Who is online

Users browsing this BMW forum: F11 535D Msport, Fox2, Google [Bot] and 31 guests