BMW: 525i sport : BMW 5 series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2014                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

525i sport

BMW forum 5 series car: E12, E28, E34, E39, E60, E61, F07, F10, F11

Moderator: Moderators

525i sport

Postby hanuman » Mon, 02 Jul 2012 18:01:15 UTC

greetings all,

just joined the forum - yesterday actually - and scrolled through some of the posts. interesting and helpful.

got my e39 sport auto nearly a month ago. not a bad ride. replaced rear tyres, inspection 2 (amber and red service indicator lights were on), replaced all 4 discs, thorough clean of the leather and a good exterior wash when i first got her.

i just seem to have one or 2 minor probs. in the morning when i first fire her up she seems to wobble, revs go up slightly, and then she will run smooth - no lights come on though.

PDC works intermittently. 1 rear sensor replaced when i bought the car - it was missing completely. i have checked them all and i can hear them click - front and rear. speakers do emitt a beep and then the button will flash.

my mechanic told me that i need rear wheel bearings soon but not urgent. i have noticed that the car makes some noise (nothing scary) even on a smoth road.

any ideas, tips or advice.

thanks in advance :D
The bigger they are......the faster they run.
hanuman
User

Posts: 7
Images: 4
Joined: Sun, 01 Jul 2012 19:08:09 UTC
BMW Members Cars: previous - 520i '90 reg Auto
Imola red

previous - 523i '99 reg Auto
Titanium silver

current - 525i sport '52 reg Auto.
Le Mans Blue.
United Kingdom (uk)

Re: 525i sport

Postby slim_boy_fat » Mon, 02 Jul 2012 18:11:55 UTC

Hi & welcome aboard.

It could be the Idle Control Valve [ICV] causing your problem, do a search on the 'Land, it's been discussed many times.

Oh, and we like to see pics on here before anyone else mentions them....... :wink:
Never underestimate the power of thrawn.
slim_boy_fat
BMW Warlord
Site Supporter

User avatar

Posts: 24394
Joined: Mon, 04 Aug 2003 17:53:54 UTC
Location: Scottish Highlands
Scotland (SC)

Re: 525i sport

Postby hanuman » Mon, 02 Jul 2012 18:28:42 UTC

hi slim_boy_fat,

thanks for the tip and I will up-load pics as soon as I get around to snapping a few

cheers
The bigger they are......the faster they run.
hanuman
User

Posts: 7
Images: 4
Joined: Sun, 01 Jul 2012 19:08:09 UTC
BMW Members Cars: previous - 520i '90 reg Auto
Imola red

previous - 523i '99 reg Auto
Titanium silver

current - 525i sport '52 reg Auto.
Le Mans Blue.
United Kingdom (uk)

Re: 525i sport

Postby bembo449 » Tue, 03 Jul 2012 05:27:35 UTC

hi there pal , i joined last week after picking up a 530i sport A , loads of info but its taking time for the folks to take any interest in my noob Q's
bembo449
User

Posts: 19
Joined: Tue, 26 Jun 2012 16:47:50 UTC
BMW Members Cars: insignia vxr
mondeo est
5 series champagne edt 2
United Kingdom (uk)

Re: 525i sport

Postby hanuman » Tue, 03 Jul 2012 15:48:11 UTC

hi bembo449,

not to worry. i guess the forum has been up and running for a while so you may really have to post something really weird/wonderful/funny to get an immediate response. i've been trolling the other posts and some of the stuff is quite practical. give it a go !
The bigger they are......the faster they run.
hanuman
User

Posts: 7
Images: 4
Joined: Sun, 01 Jul 2012 19:08:09 UTC
BMW Members Cars: previous - 520i '90 reg Auto
Imola red

previous - 523i '99 reg Auto
Titanium silver

current - 525i sport '52 reg Auto.
Le Mans Blue.
United Kingdom (uk)

Re: 525i sport

Postby bembo449 » Tue, 03 Jul 2012 20:14:27 UTC

perhaps but im an active member on several forums and they always chip in even if it has been asked a thousand times ! ive still found it useful mind ;-))
bembo449
User

Posts: 19
Joined: Tue, 26 Jun 2012 16:47:50 UTC
BMW Members Cars: insignia vxr
mondeo est
5 series champagne edt 2
United Kingdom (uk)

Re: 525i sport

Postby hanuman » Mon, 09 Jul 2012 14:10:42 UTC

hi all,

have now posted a few pics of the car. i do need to take her in for a check up. problem persists and i have also had the 'deterioration of exhaust emission values' light come on. it has since gone off on its own.....?? bizarre. either than that no other real issues to moan about.
The bigger they are......the faster they run.
hanuman
User

Posts: 7
Images: 4
Joined: Sun, 01 Jul 2012 19:08:09 UTC
BMW Members Cars: previous - 520i '90 reg Auto
Imola red

previous - 523i '99 reg Auto
Titanium silver

current - 525i sport '52 reg Auto.
Le Mans Blue.
United Kingdom (uk)

Re: 525i sport

Postby Bolosman » Mon, 09 Jul 2012 14:31:07 UTC

My 525 sport petrol used to do this too. Worst case scenario you are looking at an issue with one or more of the hydraulic valve lifters which does affect the M54 petrol engine.

Get the codes read and it will show up as a misfire one or more of the cylinders...

Bottom line is you could spend up to £800 gettting it sorted (if it is this) or you could leave it as it is. The secret is to drive of straight away after starting or as it's coming off choke and starts to misfire shake, turn the engine off for 10 secs and then restart and see if it has stopped. I ran the car like this for 3 years without any issues although it was a little worse in the winter fwiw.

I posted a thread on here a while back (E39 section though) stating the issues i had so it might be worth checking if your symptoms are the same
Bolosman
Advanced

User avatar

Posts: 666
Images: 0
Joined: Fri, 23 Sep 2005 03:24:55 UTC
BMW Members Cars: BMW 530d M Sport
Location: Midlands
United Kingdom (uk)

Re: 525i sport

Postby Trefor1 » Mon, 09 Jul 2012 18:07:50 UTC

Might be a flakey coil pack or the DIS flap (on the inlet manifold). I suggest you have someone run diagnostics.
Trefor1
Intermediate

Posts: 104
Joined: Tue, 13 Mar 2012 16:37:45 UTC
BMW Members Cars: 04 BMW E39 3.0 MSport Touring.
04 TVR T350 Targa with a few mods.
United Kingdom (uk)

Re: 525i sport

Postby hanuman » Tue, 10 Jul 2012 07:21:37 UTC

thank you forum,

i had considered chancing it.....then i also thought what if things really go pear shaped !? eventually decided that i will have it checked out. its such a shame, i've only had her a month and she's making me pull my hair out :cry:

will report when i have a verdict.
The bigger they are......the faster they run.
hanuman
User

Posts: 7
Images: 4
Joined: Sun, 01 Jul 2012 19:08:09 UTC
BMW Members Cars: previous - 520i '90 reg Auto
Imola red

previous - 523i '99 reg Auto
Titanium silver

current - 525i sport '52 reg Auto.
Le Mans Blue.
United Kingdom (uk)


  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW 5 series Forum

BMWLand: Who is online

Users browsing this BMW forum: Dubstar, sg_bmw, usam and 45 guests