BMW: 316 Ti engine Problem : BMW 3 series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2014                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

316 Ti engine Problem

BMW forum 3 series car: E21, E30, E36, E46, E90, E91, E92, E93, F30, F31, F34, F35

Moderator: Moderators

316 Ti engine Problem

Postby damo2008 » Sun, 13 May 2012 22:29:33 UTC

i have recently aquired a E36 316 ti for a few hundred quid with a engine fault on it

the engine is the N42 1.8 engine

the 'engine check' light is on however the EML light isn't i have plugged the car into the OBD Reader and i get the following faults

P0341 Camshaft Position Sensor Circuit Range/Performance

P0347 Camshaft Position Sensor Circuit Low

P0349 Camshaft Position Sensor Circuit Intermittent

the car seems to run a bit lumpy and lacks power however it has no problems starting and dosnt make any serious noise

now i know the lad who had it before me had the coil packs changed and plugs so should rule them out and if its gone to a garge they would have checked the cam sensor surly does anyone have any idea on what other things could cause this problem?

i also have read up on these engines and they a prown to the timing jumping is there simple way to test this?

any help on this would be much appreciated if anyone needs anymore info to help i will try my best

thanks
Damo
damo2008

Posts: 5
Joined: Sun, 13 May 2012 22:02:48 UTC
BMW Members Cars: E46 316 Ti
E36 316 i
England (EN)

Re: 316 Ti engine Problem

Postby damo2008 » Sun, 13 May 2012 22:30:41 UTC

sorry its a E46 316ti i got mixed up when writing the post and cannot edit the first post
damo2008

Posts: 5
Joined: Sun, 13 May 2012 22:02:48 UTC
BMW Members Cars: E46 316 Ti
E36 316 i
England (EN)

Re: 316 Ti engine Problem

Postby pjv » Mon, 14 May 2012 05:14:03 UTC

There have been a few posts here about the N42 engine and timing chain problems, usually related to chain tensioner problems causing the chain to slip out of timing. Other engines too. I think you should take the car to be checked by a BMW specialist before more damage is possibly done if the chain has in fact slipped. It might turn out to be just faulty cam sensor(s).
pjv
Intermediate

Posts: 294
Joined: Sat, 24 May 2008 07:01:31 UTC
BMW Members Cars: 2002 318Ti
Location: Melbourne
Australia (au)

Re: 316 Ti engine Problem

Postby damo2008 » Mon, 28 May 2012 16:42:27 UTC

thanks for the reply i now have had the diagnostics done

there is a misfire on cylinders 1 the specalist has found the coil packs are all good as are the plugs

they are starting to think its a valve not opening properly causing the misfire but cannot tell unless i have some engine test done by BMW with some MK08 test or somthing does anyone know of anyone that can do the test as my BMW garage are refusing to do the test without them doing a full diagnostics on the car to find the problem as they dont want to fond the problem and let someone else fix it which is understandable from there point of view but could get expenscive for myself if they take hours upon hours
damo2008

Posts: 5
Joined: Sun, 13 May 2012 22:02:48 UTC
BMW Members Cars: E46 316 Ti
E36 316 i
England (EN)


  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW 3 series Forum

BMWLand: Who is online

Users browsing this BMW forum: SteveMD and 28 guests