BMW: Rear wiper not working : BMW 1 series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2014                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

Rear wiper not working

BMW Forum 1 series car: E87, E81, E87, E88, F20

Moderator: Moderators

Rear wiper not working

Postby pp320d » Sat, 05 Jan 2013 16:49:29 UTC

I have a 1 series 2007 reg, and the rear wiper has stopped working, it started to judder then stopped all together, I found the fuse board by looking in the service book, are BMW a joke?? it is hidden away behind the glove box how on earth is a mans big stubby hands meant to get in to it, I need a torch to even see it, I have tried to get access to the wiper motor but even after unscrewing the holding screws the cover does not want to come away, any ideas?
pp320d
Newbie

Posts: 2
Joined: Sun, 25 Jan 2009 15:58:22 UTC
Location: Hull

Re: Rear wiper not working

Postby Vor » Sat, 05 Jan 2013 17:13:02 UTC

You could try to remove the base cover off the wiper to expose the shaft connection and wash off any build up of road dust and then apply some WD40 or other light penatrative lubricant and assist movement without over pressure. Hopefully you will not have blown the fuse and it will OK
I have just had to go through this with my Touring rear wiper and it worked for me HTH Vor
Vor
User

Posts: 58
Joined: Mon, 07 Jan 2008 23:59:54 UTC

Re: Rear wiper not working

Postby Nickfantastic » Fri, 11 Jan 2013 23:18:56 UTC

Check power supply and earth to motor is the first place to start. Have replaced these motors before for failing
Nickfantastic
User

Posts: 27
Joined: Wed, 19 Dec 2012 08:54:30 UTC
BMW Members Cars: E92 335d
United Kingdom (uk)


  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW 1 series Forum

BMWLand: Who is online

Users browsing this BMW forum: No registered users and 4 guests