BMW: P0135 code after replacing o2 sensor : BMW Z series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2013                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

P0135 code after replacing o2 sensor

BMW forum Z Series car: Z1, Z3, M-Z3, Z4, Z8, Z9

Moderator: Moderators

P0135 code after replacing o2 sensor

Postby laurieh » Wed, 14 Nov 2012 19:13:24 UTC

Hi all

Had an error of P0135 heater sensor bank 1 sensor 1

The guy i brought the car from had replaced this with a non OEM cut and join jobby.

So i purchase a used OEM o2 sensor from a good reliable supplier I have used before and fitted this on sunday. Cleared code and this morning the engine light came on, so plugged in my diagnostic tool and the same fault has appeared.

Just to confirm that the o2 sensor bank 1 is the sensor 'pre-cat' (nearest to engine)

Could there be a wiring fault or has my supplier let me down??

Cheers
laurieh
User

Posts: 8
Joined: Sun, 12 Aug 2012 17:22:41 UTC
BMW Members Cars: BMW Z3 1.9i Topiaz Blue
United Kingdom (uk)

  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW Z series Forum

BMWLand: Who is online

Users browsing this BMW forum: Exabot [Bot], Yahoo [Bot] and 3 guests