BMW: i Drive problem : BMW 6 Series Forum • BMWLand

  BMW Forum: Car help, questions, answers, BMW discussion forum  
BMW Forum for UK BMW Car owners : Where Power Meets Control

BMW Forum: BMWLand Forum Portal Entrance BMW Forum: BMWLand - Forums for UK BMW Owners BMW Discounts & Support for BMWLand members BMW Forum Twitter, RSS, Facebook for BMWLand members BMW Car Insurance Discount BMWLand: Contact Us BMW Paint Repair discounts for BMWLand members BMW Oil Discount for BMW Engines BMW Car Tyre Discounts for BMWLand Members BMW Car Parts: Genuine BMW Parts Discount for BMWLand Members BMW ECU mapping BMW Swirl Flaps

www.BMWLand.co.uk ©2014                           Contact [email protected]

Peake BMW Diagnostics  
BMW Car Insurance Discount
  
  

i Drive problem

BMW forum 6 series car: E24, E63, E64, F12, F13

Moderator: Moderators

i Drive problem

Postby NCK » Wed, 28 Mar 2012 17:30:30 UTC

I have a BMW 630i (2005) with 34000 miles and the i Drive has stopped working. The control spins freely with no resistence and the radio will not work. Has anybody had the same problem? is it an electrical fault or easy fix?
Any help who be great as it seems to be one problem after the other at the minute with my 6 series.
NCK
User

Posts: 6
Joined: Mon, 06 Feb 2012 18:43:08 UTC
BMW Members Cars: 2005 BMW 630
United Kingdom (uk)

Re: i Drive problem

Postby 6Appeal » Wed, 28 Mar 2012 20:36:48 UTC

Have you checked the fuse?
I can resist everything except temptation.
Deep Sea Blue 640d GC
6Appeal
BMW Warlord

User avatar

Posts: 1088
Joined: Sat, 14 Jun 2008 21:32:23 UTC

Re: i Drive problem

Postby NCK » Thu, 29 Mar 2012 15:52:02 UTC

Thanks, yeah checked fuse last night and it was ok. Left the car over night to go to sleep and got in it this morning and it was fine and back to normal, strange but working fine now.
NCK
User

Posts: 6
Joined: Mon, 06 Feb 2012 18:43:08 UTC
BMW Members Cars: 2005 BMW 630
United Kingdom (uk)

Re: i Drive problem

Postby AMW » Thu, 29 Mar 2012 16:38:08 UTC

the yankee bmw guys seem to accept that regular rebooting of idrive system is the norm , ,anyhow heres a link that may help you in the future
http://www.tyresmoke.net/forum/bmw-tech ... drive.html
Audi A6 Avant / family taxi
Astravan for daily duties / yes its white !
Z4 weekender
AMW
Overdrive
Site Supporter

Posts: 330
Joined: Wed, 28 Dec 2011 07:55:39 UTC
BMW Members Cars: current BMW X3 3.0i
gone in order / 645Ci / 520d / Z4coupe / 330d
England (EN)


  • Forum Topics on BMWLand that may be of intetest to you
    Replies
    Views
    Last Forum post

Return to BMW 6 Series Forum

BMWLand: Who is online

Users browsing this BMW forum: No registered users and 3 guests